Some hands not importing?

Experiencing technical difficulties? Think you've found a problem with PokerTracker 3? Report it here.

Moderator: Moderators

Some hands not importing?

Postby rubbersoul » Sun Sep 14, 2008 3:46 am

PokerStars: Unable to import hand (#20393430824). Reason: Unable to execute query: COPY holdem_hand_player_combinations FROM STDIN;; Reason: Fatal Error (ERROR: invalid page header in block 19 of r......

This is the message i'm getting in the auto import section. I'm running PT3 on vista. Any ideas on whats the cause and cure for this??
rubbersoul
 
Posts: 100
Joined: Tue Jul 29, 2008 5:24 pm

Re: Some hands not importing?

Postby WhiteRider » Sun Sep 14, 2008 4:24 am

Please see the Database / Postgres FAQ.
If you can't find your problem in there, please post the full error message.
WhiteRider
Moderator
 
Posts: 52774
Joined: Sat Jan 19, 2008 7:06 pm
Location: UK

Re: Some hands not importing?

Postby rubbersoul » Sun Sep 14, 2008 9:34 am

2008/09/14 14:28:58: PokerStars: Unable to import hand (#20397518120). Reason: Unable to execute query: COPY holdem_hand_player_combinations FROM STDIN;; Reason: Fatal Error (ERROR: invalid page header in block 19 of relation "hhpc:idx1-id_hand" CONTEXT: COPY holdem_hand_player_combinations, line 1: "9515 2104 f t f f f f f f f 0 0 0 f f f f t t 0 0 f t f f f f f f f 0 0 0 f f f t 0 0 f f f f f t f ..." )



Thats the full error message.
rubbersoul
 
Posts: 100
Joined: Tue Jul 29, 2008 5:24 pm

Re: Some hands not importing?

Postby WhiteRider » Sun Sep 14, 2008 11:06 am

There are two main reasons for this error. The first is a result of data corruption from a computer crash that requires reindexing your database. You can reindex your database from the PostgreSQL command prompt. Click Start --> Programs --> PostgreSQL --> Command prompt. At the prompt that appears, type “reindexdb -a” and hit enter. Be aware that if you have large databases this may take a while, so be patient and wait for it to finish.
(If the re-index doesn't work because you are not logged in as user 'postgres' enter: "reindexdb -U postgres -a").

The second reason for this error is a result of faulty hardware. You can set PostgreSQL to ignore these errors by clicking Start --> Programs --> PostgreSQL --> Configuration Files --> Edit postgresql.conf. In the configuration file that appears, go to the bottom of the file and add the text “zero_damaged_pages = on” on a new line and then save and close the file. Click Start --> Programs --> PostgreSQL --> Reload Configuration and PostgreSQL will ignore the damaged data. If you continue to have problems with that hard drive, you should consider replacing it.
WhiteRider
Moderator
 
Posts: 52774
Joined: Sat Jan 19, 2008 7:06 pm
Location: UK

Re: Some hands not importing?

Postby rubbersoul » Sun Sep 14, 2008 3:01 pm

after i type in reindexdb -a and press enter it seem to ask me for a password?

What do i do here?
rubbersoul
 
Posts: 100
Joined: Tue Jul 29, 2008 5:24 pm

Re: Some hands not importing?

Postby WhiteRider » Sun Sep 14, 2008 5:15 pm

The default password is 'dbpass' (without quotes). If you changed it, obviously enter your own password.
If you can't get that to work or you don't know the password, you can remove the need for postgres passwords: How To: Remove PostgreSQL Password
WhiteRider
Moderator
 
Posts: 52774
Joined: Sat Jan 19, 2008 7:06 pm
Location: UK

Re: Some hands not importing?

Postby rubbersoul » Sun Sep 14, 2008 7:33 pm

Disable the password then entering this- reindexdb -U postgres -a seems to have done the trick.
Cheers WR
rubbersoul
 
Posts: 100
Joined: Tue Jul 29, 2008 5:24 pm


Return to Technical Support / Bug Reports [Read Only]

Who is online

Users browsing this forum: No registered users and 1 guest

cron
highfalutin