remote postgres

Experiencing technical difficulties? Think you've found a problem with PokerTracker 3? Report it here.

Moderator: Moderators

remote postgres

Postby kbfc » Thu Jan 24, 2008 11:02 pm

From the 2+2 thread:

Quote:
Originally Posted by kbfc
I downloaded the "without postgres" version. I already have the PGODBC driver installed on this machine from using it with PT2 and PAHUD.

Whenever I try to run PT3, it immediately gives me a splash screen with "Fatal Error - PokerTracker cannot operate without PostgreSQL."
--------------------------------------

_dave_ :
Does it install OK then this when you start it? or this is during installation?

This shouldn't happen - please make a post on the pt3 forums to make sure Josh / AP10 see it - maybe they changed something postgres detection related for the beta I don't know about.

It is *certainly* not intentional to require postgres on localhost.
-------------------------------------------------------------------------

Installation was fine. This is when trying to start the program. I'm running as admin on vista.
kbfc
 
Posts: 1
Joined: Thu Jan 24, 2008 8:54 pm

Re: remote postgres

Postby APerfect10 » Thu Jan 24, 2008 11:50 pm

Sounds like a design flaw since you do not have PostgreSQL installed on the local machine (which should be easily fixable).

In the mean time, open "My Computer" and browse to your main PokekerTracker 3 directory then go data/config. Open "PokerTracker.cfg" in Notepad. Under [Database] either add (or if already there change the settings) to point to your remote database.

[coder5z]Default.Postgres.Server=
Default.Postgres.Port=
Default.Postgres.User=
Default.Postgres.Password=[/coder5z]

File->Save and start PokerTracker 3.

Or you could always install PostgreSQL on your local machine and point PT3 to your remote database.

Best regards,

Derek
APerfect10
Site Admin
 
Posts: 4414
Joined: Sat Dec 08, 2007 6:03 pm

Re: remote postgres

Postby beaster » Thu Jan 24, 2008 11:55 pm

The .cfg file changes didn't work for me. No PostgreSQL on localhost, just on my remote Linux box.
beaster
 
Posts: 6
Joined: Thu Jan 24, 2008 11:45 pm

Re: remote postgres

Postby APerfect10 » Thu Jan 24, 2008 11:58 pm

[quote="beaster"p31]The .cfg file changes didn't work for me. No PostgreSQL on localhost, just on my remote Linux box.[/quotep31]

And you put your remote linux box's IP address and port into the configuration?

What happened when you started PT3?

-AP10
APerfect10
Site Admin
 
Posts: 4414
Joined: Sat Dec 08, 2007 6:03 pm

Re: remote postgres

Postby _dave_ » Fri Jan 25, 2008 12:00 am

[quote="APerfect10"72h]Sounds like a design flaw since you do not have PostgreSQL installed on the local machine (which should be easily fixable).

In the mean time, open "My Computer" and browse to your main PokekerTracker 3 directory then go data/config. Open "PokerTracker.cfg" in Notepad. Under [Database] either add (or if already there change the settings) to point to your remote database.

[code72h]Default.Postgres.Server=
Default.Postgres.Port=
Default.Postgres.User=
Default.Postgres.Password=[/code72h]

File->Save and start PokerTracker 3.

Or you could always install PostgreSQL on your local machine and point PT3 to your remote database.

Best regards,

Derek[/quote72h]

I haven't checked... "Default.Postgres.Password=" is not cleartext I assume? perhaps this is why is failing (needs MD5'ed or whatever)?
_dave_
 
Posts: 1147
Joined: Sun Dec 09, 2007 6:19 pm

Re: remote postgres

Postby _dave_ » Fri Jan 25, 2008 12:01 am

and (OT) what is breaking quotes today?
_dave_
 
Posts: 1147
Joined: Sun Dec 09, 2007 6:19 pm

Re: remote postgres

Postby APerfect10 » Fri Jan 25, 2008 12:06 am

[quote="_dave_"3h4]and (OT) what is breaking quotes today?[/quote3h4]

You have "Disable BBCode" checked under Options directly below the editor.

-AP10
APerfect10
Site Admin
 
Posts: 4414
Joined: Sat Dec 08, 2007 6:03 pm

Re: remote postgres

Postby the other mike » Fri Jan 25, 2008 12:28 am

I have the same problem and pasting in/filling out ap10*'s cfg entries doesn't work; using my private ip doesn't work, "localhost" doesn't work. odbc drivers are installed just fine as many other apps use linux pgsql server no problem.
the other mike
Moderator
 
Posts: 271
Joined: Fri Jan 25, 2008 12:16 am

Re: remote postgres

Postby _dave_ » Fri Jan 25, 2008 12:31 am

this is a beat :( need to test, I'm sure this didn't happen earlier. Is it now checking for the user "postgres"?

For now I suggest install a local posgres (presumably no need to have it running).
_dave_
 
Posts: 1147
Joined: Sun Dec 09, 2007 6:19 pm

Re: remote postgres

Postby APerfect10 » Fri Jan 25, 2008 1:02 am

Try installing Postgres on your local machine and then pointing PT3 to your remote db and see if it recognizes it....

Best regards,

Derek
APerfect10
Site Admin
 
Posts: 4414
Joined: Sat Dec 08, 2007 6:03 pm

Next

Return to Technical Support / Bug Reports [Read Only]

Who is online

Users browsing this forum: No registered users and 5 guests

cron
highfalutin