Page 1 of 1

Can't restore database

PostPosted: Thu Dec 17, 2020 6:45 am
by Kerozhaine
Hello everyone,

Just wanted to move my database to a brand new computer (both on W10)

I made 2 backup versions of my database on the first computer (one with Processed hands, and one without) (I saw a forum post saying it can be buggy if we enabled Processed hand backup so I tried without too)

On the new computer, I installed PT4, and when tring to access to the Restore features (by clicking Database Management, then on the Restore button) PT4 get stuck and dont respond.

I am only prompted to enter the backup file path (backup file is located on my Desktop), and then, PT4 get stuck, and dont respond for hours (whatever backup file i choose (with/without processed hands)) (and I never saw the restore window as we can see in the backup/restore official documentation).

Could you help me ? Running version 4.15.27 on both computer. (I am unable to open the Restore window from the first computer too, so I am not sure that this issue is hardware related...)

Re: Can't restore database

PostPosted: Thu Dec 17, 2020 9:18 am
by Flag_Hippo
In PokerTracker4 click 'Configure -> Options' and if 'Logging Enabled' doesn't have a check mark turn it on. Close/restart PokerTracker 4. Move your backup file from your desktop to the root of C:\, run the restore from there and make sure to disable everything under 'Optional Files' when restoring. It is normal for PokerTracker 4 to be unresponsive while a database is being restored (PostgreSQL will be using CPU in task manager) but if you have any issue send us the details and your log file in a Support Ticket:

C:\Users\{Windows Login}\AppData\Local\PokerTracker 4\Logs\PokerTracker4.log

If you do not see the AppData folder in Windows File Explorer then please refer to this guide.

Re: Can't restore database

PostPosted: Fri Dec 18, 2020 5:53 pm
by Kerozhaine
Finally managed to restore my database

Here is some feedback : I succeded the restore by recreating a new backup without any optionnal file, and it worked as a charm.

I think that you should rework a bit the backup/restore documentation to specify that adding optionnal file to backup increase HUGELY the restore time :
- If you add "note definitions" to the backup : when restoring, PT4 seems to analyse the provided .zip file before rendering the "Restore" page, on which you can select "optionnal file" to load and start the restore (up to 2 hours of PT4 freeze (program dont respond) and there is no feedback at all for the user.
- You should precise that some folder should be simply copied to the new PT4 install instead of restoring it from a backup. --> I spent 30 hours on a brand new (and powerful) PC, just for restoring 5% of my note definition during my first try...)
- You should precise / highlight that NoteCaddy should be closed before lauching a restore too

Make a better documentation should save time both for users and for you moderators ;)


Re: Can't restore database

PostPosted: Sat Dec 19, 2020 8:31 am
by Flag_Hippo
Thank you for reporting back. We are aware of this and there may be changes in a future release of PokerTracker 4.