updated to 4.17.1 issues

Questions and discussion about PokerTracker 4 for Windows

Moderators: WhiteRider, kraada, Flag_Hippo, morny, Moderators

updated to 4.17.1 issues

Postby MunKay » Sun Jul 17, 2022 9:10 pm

So many where to begin...

First off hud doesn't work at all. Database is corrupted and cannot import hands or anything else for that matter. global stats doesn't work, etc etc etc

keeps throwing block errors I did back up files before update but it won't load the backup files now either says they can't because of block errors.

Im literally losing 3-4 years worth of data and stats
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby MunKay » Sun Jul 17, 2022 9:21 pm

Ph one of the errors is that it can’t get hands cause it’s configured to import into an outdated database whatever that means
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby Flag_Hippo » Mon Jul 18, 2022 3:52 am

Please turn on 'Enable Logging' in PokerTracker 4 via 'Configure -> Options' and then restart PokerTracker 4. Next reproduce this issue and then attach your support bundle to a Support Ticket so we can check your logs and advise you accordingly. The support bundle is created via the 'File -> Create Support Bundle' menu option in PokerTracker 4.
Flag_Hippo
Moderator
 
Posts: 17048
Joined: Tue Jan 31, 2012 7:50 am

Re: updated to 4.17.1 issues

Postby MunKay » Mon Jul 18, 2022 1:52 pm

Ok did what you asked. Enable logging was already highlighted, created support bundle its saved to my desktop and I did attach it to a support ticket I started yesterday. No one has responded to the support ticket I started yesterday, but I went ahead and responded to that ticket with the support bundle as you mentioned. Not sure if it will be helpful because the issues I’m facing happen at the start of pt4.

When I start it up it says I need to update the database and that it could take time. Ok, cool I click start database update. It says then I should back up my database, which I did before downloading new version so I click no cause I should be good to go. Then thirty seconds later I get this error:

Error updating database: PokerTracker 4 Database

Error:
Error: Unable to execute query: Fatal Error; Reason: ERROR: could not read block 52 in file “base/16393/16837”: Invalid argument.

I click ok cause what else can I do, really?

If I click start getting hands it shows errors which say:

Error: Unable to begin feeder import process. Reason: PokerTracker is configured to an outdated database. This must be corrected before import can succeed.

So I went into database management and tried to create a new database thinking I can atleast get it up and running and then worry about my hand histories later. Created a new database and it still has the same issues. Even though I created a new one it still says it is outdated when trying to get hands.

Also, when I go into viewing my stats they’re all off which doesn’t make sense. If I created a new database it shouldn’t have any existing information cause it was unable to get hands so I shouldn’t have any stats. So back into database management I go and I I try to restore my database which throws the “block 52” error I stated earlier.

I’d attach pictures in here but for some reason it won’t let me do that either.

At this point, would it be better to fully delet PT4 and download a fresh copy. Then I could download hand histories from my different accounts and upload them that way?
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby MunKay » Mon Jul 18, 2022 1:56 pm

Also, I tried rebuilding the cache as well thinking it might correct whatever error it was seeing and that threw more errors as well. I also tried to stopping service and restarting service on the database but to no avail.
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby MunKay » Mon Jul 18, 2022 9:51 pm

Still no response from support… waiting…
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby Flag_Hippo » Tue Jul 19, 2022 5:32 am

Unfortunately a read block error indicates the database is damaged which is usually caused by data corruption from a computer crash/powercut while the database was active although it can also be caused by faulty hardware. To attempt to fix it you can reindex your database by going to 'Database -> Database Management'. Select the affected database then click 'Housekeeping -> Reindex'. After the housekeeping is complete we recommend that you will also need to rebuild the database cache via 'Rebuild Cache -> Full Cache Rebuild'.

If the original error doesn't get fixed then you should create a new database and reimport your hands although while not recommended you can set PostgreSQL to ignore those errors by editing the postgresql.conf file.
MunKay wrote:So I went into database management and tried to create a new database thinking I can atleast get it up and running and then worry about my hand histories later. Created a new database and it still has the same issues. Even though I created a new one it still says it is outdated when trying to get hands.

Also, when I go into viewing my stats they’re all off which doesn’t make sense. If I created a new database it shouldn’t have any existing information cause it was unable to get hands so I shouldn’t have any stats. So back into database management I go and I I try to restore my database which throws the “block 52” error I stated earlier.

When creating a new database make sure it is set as the default/active database:

Guide: Database Management

and that hands are set to import into the current active database via 'Configure -> Site & Import Options -> Preferences'.
Flag_Hippo
Moderator
 
Posts: 17048
Joined: Tue Jan 31, 2012 7:50 am

Re: updated to 4.17.1 issues

Postby MunKay » Tue Jul 19, 2022 11:50 am

Ok so, hand import problem mostly fixed. When I go into configure and actively select which database I want hands to go into, then select get hands it only throws errors to two sites I don’t use anymore so that’s fine should work then. However, when I go into database management it doesn’t give me the option to perform housekeeping it’s greyed out and unselectable. Not sure why or what the issue there is.
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby MunKay » Tue Jul 19, 2022 11:55 am

Thanks hippo for helping as I still have yet to receive any help from “support”. Not sure if normal response time for them is 3-4days or what the issue is there but whatever. Any way, I went to rebuild the cache in my current “new” database and it’s throwing those same block errors even though it’s the new database. How do I delete these databases and start over? At this point I want working software. So, how do I get rid of these damned corrupted databases lol. I can always download hands later. I’m asking because the software is saying I cannot delete the active database. Right now what I want to do is basically have a fresh install I don’t care about the history anymore but not sure how to do it.
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Re: updated to 4.17.1 issues

Postby MunKay » Tue Jul 19, 2022 12:03 pm

Oh god… now pt4 just crashed due to a fatal error? And have to submit a support log… seriously this thing is a piece of… rn
MunKay
 
Posts: 12
Joined: Fri May 31, 2019 11:06 am

Next

Return to PokerTracker 4

Who is online

Users browsing this forum: No registered users and 7 guests