Unfortunately a read block error indicates the database is damaged which is usually caused by data corruption from a computer crash/powercut while the database was active although it can also be caused by faulty hardware. To attempt to fix it you can reindex your database by going to 'Database -> Database Management'. Select the affected database then click 'Housekeeping -> Reindex'. After the housekeeping is complete we recommend that you will also need to rebuild the database cache via 'Rebuild Cache -> Full Cache Rebuild'.
If the original error doesn't get fixed then you should
create a new database and reimport your hands although while not recommended you can set PostgreSQL to ignore those errors by
editing the postgresql.conf file.
MunKay wrote:So I went into database management and tried to create a new database thinking I can atleast get it up and running and then worry about my hand histories later. Created a new database and it still has the same issues. Even though I created a new one it still says it is outdated when trying to get hands.
Also, when I go into viewing my stats they’re all off which doesn’t make sense. If I created a new database it shouldn’t have any existing information cause it was unable to get hands so I shouldn’t have any stats. So back into database management I go and I I try to restore my database which throws the “block 52” error I stated earlier.
When creating a new database make sure it is set as the default/active database:
Guide: Database Managementand that hands are set to import into the current active database via 'Configure -> Site & Import Options -> Preferences'.